周梦康 发表于 2017-08-30 2557 次浏览 标签 : Pandora Boot

自己现在对公司的Pandora Boot启动方式还是不了,所以有时候出了些问题也不知道为什么,比如下面的这个情况:

├── pom.xml
├── yq-bridge-service
│   ├── pom.xml
│   ├── src
│   ├── target
│   └── yq-bridge-service.iml
├── yq-bridge-start
│   ├── pom.xml
│   ├── src
│   ├── target
│   └── yq-bridge-start.iml
├── yq-bridge.iml
└── yq-bridge.release

在模块yq-bridge-start首先引入了包,版本是0.1.0
后面在yq-bridge-service也用到了这个包,但是新增的方法是在0.2.0版本里加入的,所以我在yq-bridge-servicepom.xml里面的版本是0.2.0

最后导致服务器无法启动,报错信息是

Caused by: java.lang.ClassNotFoundException: com.aliyun.crm.service.QueryStudentInfoService

最后发现把yq-bridge-start的那个包的版本号改成0.2.0才能启动。

👇 下面是我的公众号,高质量的博文我会第一时间同步到公众号,给个关注吧!

评论列表