周梦康 发表于 2018-06-05 1728 次浏览 标签 : Java

我首先安装了,java 10,然后发现安装的 ide 都跑不起来了,估计是 jdk 版本过高的原因导致的。

所以我又安装了 java 8。但是在命令行查看 java -version 还是 10.0.0 。

mengkangdeMacBook-Pro:Frameworks mengkang$ cd /Library/Java/JavaVirtualMachines/
mengkangdeMacBook-Pro:JavaVirtualMachines mengkang$ ls
jdk-10.0.1.jdk        jdk1.8.0_171.jdk
mengkangdeMacBook-Pro:JavaVirtualMachines mengkang$ sudo rm -rf jdk-10.0.1.jdk/
Password:
mengkangdeMacBook-Pro:JavaVirtualMachines mengkang$ ls
jdk1.8.0_171.jdk
mengkangdeMacBook-Pro:JavaVirtualMachines mengkang$ java -version
java version "1.8.0_171"
Java(TM) SE Runtime Environment (build 1.8.0_171-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.171-b11, mixed mode)

评论列表