周梦康 发表于 2017-10-12 1941 次浏览 标签 : phpbrew

因为要直播分享,我用 brew 安装了 php70-swoole,但是我看到命令里给我新安装了一个php7.0.24_16的版本,因为 swoole 要求依赖这个小版本。
我看到/usr/local/etc/php/7.0/php.ini重新生成了,但是之前的扩展并没有丢失。

因为在编译的时候使用了一个--with-config-file-scan-dir=/usr/local/etc/php/7.0/conf.d 参数。
这样就会在读取完php.ini之后读取conf.d下面的扩展配置。
这样就和 php.ini 配置解耦了。

评论列表